Who Understands Network Statements?

A couple of weeks ago, I asked some questions about an obscure OSPF configuration. I found the scenario fun to write and share. Therefore, I wanted to offer another odd configuration that might challenge readers to think through the resulting behavior of a Cisco device. This particular challenge is a quick and dirty RIP configuration based on the following scenario.

RIP Statements

R1 Configuration

interface FastEthernet0/0
 description To Host1
 ip address 10.1.1.1 255.255.255.0
!
interface FastEthernet0/1
 description To R2
 ip address 10.100.100.1 255.255.255.0
!
router rip
 network 10.100.100.0

R2 Configuration

interface FastEthernet0/0
 description To Host2
 ip address 10.2.2.2 255.255.255.0
!
interface FastEthernet0/1
 description To R1
 ip address 10.100.100.2 255.255.255.0
!
router rip
 network 10.100.100.0

Question

Assuming Host1 and Host2 are configured with the appropriate address and default gateway, which following two statements are true?

  • Host1 can reach Host2
  • Host2 cannot reach Host1
  • show run will reveal the configuration above
  • show run will reveal differences from what is shown

A question like this can reveal whether or not an individual has experience configuring interior gateway protocols. Those who have worked with IOS will confirm the following two statements are correct in this scenario.

  • Host1 can reach Host2
  • show run will reveal differences from what is shown

Explanation

When the network statement is used under router rip, the address is accepted whether it is the correct classful network address or not. Any address that isn’t that of a classful network is converted as appropriate based on rules that define IP address classes. As shown below, network 10.100.100.0 would become network 10.0.0.0 and creates a valid RIP configuration.

R1(config)#router rip
R1(config-router)#network 10.100.100.0
R1(config-router)#^Z
R1#show run | sec router rip
router rip
 network 10.0.0.0

Additional Information

About Paul Stewart, CCIE 26009 (Security)

Paul is a Network and Security Engineer, Trainer and Blogger who enjoys understanding how things really work. With over 15 years of experience in the technology industry, Paul has helped many organizations build, maintain and secure their networks and systems.
This entry was posted in CCNA, Certification, Network, Technology and tagged , , . Bookmark the permalink.

One Response to Who Understands Network Statements?

  1. Pingback: Cisco IOS - Understanding IGP Network Statements - PacketU

Leave a Reply